ATI driver problem


I am trying to install the driver found at ati’s homepage - using redhat 9.

The thing is, it seems that the driver is working fine - it is installed, i can see that the screen config in XF86Config-4 is fine - and it starts up(it a pretty low resolution though-800x600 or so).

but fglxrinfo still shows that mesa3d driver - I have tried to force it into loading mine by replacing the ones from XFree86-devel with the fglrx one.

it doesnt help. I’m stuck, and have no idea what to do next, so any hints will be greatly appreciated.


Hello I,ve just posted an ati query as well.
I may be able to help you.
Did it complain about a conflict with mesa lbgl when installing?
If so you can safely use the --force option according to the ati website. I tried this and works fine. The alternative is to remove mesa first but use the --nodeps switch both work.
also did you have the kernel sources installed? It must have sources installed to build the driver modules.
I will get back to you if needed.
Hope this helps from relative newcomer getting a sore head from trying to learn everything linux.

Me again
Found good forum that explains in more detail.
follow this link

You might also want to make sure that you have DRI enabled. Indirect rendering always falls back to the software Mesa driver. If direct rendering is not enabled check the X logs for errors and the XF86Config4 file.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.