ATI bug when working with 1280x960


I’m using the screen resolution 1280x960 because it is exactly 4:3. I use this because my digicam and scanned slides have the same ratio so it is displayed unstretched.

BUT: Very often when starting an OpenGL application, there is a 15 seconds delay before the window comes up. When switching to 1280x1024 everything is alright and the apps start at once. So ATI seems to provide better access to the standard resolutions. My nVidia card worked normal at other resolutions (I just moved from GF4MX to Radeon9600Pro).

I debugged a little bit in my application and realized, that it hangs in the SetPixelFormat function.

Just wanted to share this information, maybe somebody can proof it too,


[This message has been edited by Kilam Malik (edited 12-15-2003).]

That happened to me, too, for a while! It was -any- time that I was setting the pixel format in -any- OpenGL program, though. Resolution, fullscreen/windowed. . . nothing made a difference. Then I shut down my firewall, tried again. . . and everything was fine. Brought my firewall back up and tried yet again. . . and everything was fine. Basically, I have no idea as to what the smeg was going on!

1280 × 1024 is a relic from AutoCAD. 1280 × 960 should be the “standard”.