ATI bug, regarding with uniforms in FS

I’ve detected an strange behaviour with an ATI9600XT and latest Catalyst drivers.
I wasn’t able to reproduce the bug with a simple application, but I’m 99% sure that this a driver bug.
This ‘problem’ could be reproduced with the Shader Designer. Open the dimple shader, and instead of see a dimpled rendered mesh, you will get a gold mesh with a specular effect.
To get the shader running as spected, comment the lines:
uniform float Density;
uniform float Size;

, and uncomment these ones:
//const float Density = 16.0;
//const float Size = 0.25;
Hit F4 to recompile the shader.

I’ve tested the locations reported when the application uploads the uniforms, and they seems to be valid (0,1,2,3, etc)

As said, I wasn’t able to reproduce this issue with a sample application, but this only happens with ATI cards. It seems that uniforms (into Fragment Shaders) aren’t correctly updated.

Another test can be tried is to comment all fragment shader lines, and write “gl_FragColor = vec4(Scale);” (and write uniform float Scale; at the beggining, because this is a VS used uniform)

This may produce a white mesh, but if you uncomment all code, leaving the gl_FragColor = vec4(Scale); at the end, and removing the other gl_FragColor line, you will get a dark grey (or other undefined color) mesh.

Anybody has experienced something similar to this? maybe with the brick shader, getting green blocks over a red background?

ehh… given that setting uniforms to the fragment shader is a pretty common thing which usually works fine and that you can’t reproduce it with your own sources, doesn’t it sound more like a problem with shader designer?
(and ofcourse some difference between nv and ati drivers)

When the program works fine with NV and 3DLabs cards, even using NVEmulate, WildCat VP or Realizm, when the uniforms are correctly uploaded (they reports a correct location), and when some uniforms works while others doesn’t, in the same shader, this makes me think about a problem external to the Shader Designer.
I remember a post, some time ago (now dissapeared, caused by one of the resets of this forum) about problems like this, regarding with uniforms in fragment shader and the brick shader for example, or with samplers that doesn’t worked correctly.

But it is possible that the problem be in the Shader Designer, so, this is the main reason of my post: try to contact with anybody that had this problem (I’m sure that there are people that had this problem) and ask them if they were able to solve it, and how to.


I have a similar problem in the game I’m currently developing. I sent a demo version to them in November and they where they can reproduce it but in the latest drivers it is not solved (although it has small differences depending on the Catalyst version so it seems that some work has been done).

Hope this helps.

At least, I know that I’m not becoming crazy, thanks :slight_smile:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.