Application hanging with NVidia drivers 178.13?

Is anyone else experiencing their application “hanging” for 10-20 seconds when it ends, using NVidia’s latest GEForce drivers? This has never occured before.

Nope, but I’m getting a crash with them in by VBO that in code that’s been working for 2 years. Could well be my code, I need to find the time to investigate (6800 card).

Was having few problems with drivers as well.
Got a good answer in the forum:
Most differences caused by driver change are caused by bugs in the application itself.
And thats very true. I found the bug in my code later.

Deleting all resources before shutting down the process (like textures, **bufferojects, shaders, …) fixed it for me on vista x64.

Earlier nvidia drivers didn’t had problems with unreleased resources.

However, I tested it under XP x86 and … again that 20sec hang on process cleanup,
so maybe i missed some leaks (which is very likely),
or that hang is caused by a total different bug.

It should not be necessary to manually delete everything.

I wouldn’t think so either, as the same goes for new/malloc memory in an app, if you allocate it once and don’t delete it the OS should reclaim it once the app shuts down. But who knows, what I think and what are are so far apart! :wink:


i only assume, that if u dont manually delete,
the new nvidia driver versions in some occasions are hanging 10-20sec at automatic process cleanup,
where earlier nvidia drivers did fine,

i assume that, because i was able to fix the hanging,
by manually releasing all allocated gl resources

the bug for that hanging could be in the driver process deinitialization, or in my app,
that may corrupt private memory of the nvidia opengl dll.

but due to the fact, u have the same issue,
there’s some chance its a driver bug

FWIW it was my code. Missing a disable of tex coord array. Just bad luck I guess that it worked before.

My application hangs as well but only for a few seconds, time to finally start using those std::auto_ptr’s :wink:

Another thing with 178.13 drivers; anyone else having problems with anisotropic filtering? If I try to enable it from the app using


nothing happens. Works fine when I force it on from nvidia control panel…