Anyone had lock-up problems with XFree86 4.x/GNU/Linux and nVidia drivers?

No, I am NOT a newbie, I have tried everything in the FAQ’s. I have had similar problems with some older drivers for Windoze 9x (which were fixed with new driver releases). Also, have had problems with open-source driver (nv) that comes with XFree86 4.
I think that the problem is specific to my Creative Riva TNT model.

Funnily, doing OpenGL programming, everything works fine doing 2D drawings and very simple (1 model) 3D programs, but the minute I put a model BEHIND the above 1 model, it locks up! i.e. no magic SysRQ key stuff works, won’t even respond to pings or APM sleep requests. Also locks up in certain circumstances when doing DGA stuff.

I don’t think this problem will be fixed too soon, but I just want to know if anybody else has had these problems.

As I said, I am not a newbie, and this is NOT related to any Mesa remnants on my system. Trust me. Also, I HAVE disabled AGP.

I had the exact same problem, in my case it was fixed by killing AGP, but you said that you have allready tryed that. do you have a SMP box I do and nothing I tryed worked till 0.9.5, someone frome Nvidia said that the linux drivers may lock up if you have the kernel compiled with SMP. The 0.9.6 dirvers workd for me with AGPGART on in the kernel. so my problem is defently with AGP (same thing happend in Win2K unless I put AGP to 1X yesing power strip) so you may gave a diferent problem but the symptoms are the same
p.s. my system is:
PII 400 X2
GX mobo
Geforce 1 vidcard
Linux kernel 2.4.1