anonymous_jit_identity exception


I got a anonymous_jit_identity exception when building my program. In my kernel I use one function that I use twice. If I comment out one function call, the excpetion disappears…Someone knows how to deal with the anonymous_jit_identity, I cannot debug my code, so thats a big problem. And I’m getting those strange exceptions almost all the time…


i just had exactly the same problem here.

my code worked before, but then i added a new function. then the code didn’t compile. even if i removed the newly added function, the code didn’t compile.

i read back the compiling information, it says this:

retrieving binary for ‘anonymous_jit_identity’, for gpu=‘sm_11’, usage mode=’

the problem is that, i removed almost everything from my code and only left an empty entry function like this:

the code still doesn’t compile and gives the same error. i don’t understand.

__kernel void VectorAdd(int iNumElements)

can anybody help me?

i’m using macbook with nv9400 under windows xp.


i tried to replace the “” demo code with my “problematic” opencl code, and it does compile!

so now i guess the problem is somewhere in my c++ code.

i don’t understand.

i also tried the same c++ project under windows vista with 8800 gtx, same problem.

i found the problem.

can’t believe it was so stupid.

ciErr1 = clBuildProgram(cpProgram, 0, NULL, NULL, NULL, NULL);
    shrLog(LOGBOTH, 0, "clBuildProgram...

 if (ciErr1 != CL_SUCCESS)

i used this code to compile the program, however, i missed the line " if (ciErr1 != CL_SUCCESS)" when i pasted the code from another line.

so no matter it compiles or not, the code gets into the build error handling part.

can’t believe i wasted the entire afternoon on this. i kinda feel shame to post my problem and the stupid code here.