Annoying texture problem with a 3d spinning cube

I’ve done my fair share of texture mapping, and I’m running into something I’ve never experienced before.

I’m selecting my texture, then passing 36 vertices (of a cube) into the pipeline.

I’m slowly spinning it around the y-axis, and I’ve noticed that whenever the front side is in front of the back side, the texture of the back side shows through the front! (ie. it looks like the front side temporarily disappears and is replaced by the back side texture)…

I’ve tried everything from disabling blending,the depth buffer, cull mode and it’s STILL happening…AGGHH!

Any ideas?? I’m at my wits end here with this stupid problem…

enable depth test and if that doesn’t work and you are back face culling, verify that all of your quads were generated with the same winding - clockwise or counter-clockwise.

it’s quite strange indeed.Post your code here and let us have look.Just curious ,what kind of cube has 36 vertex while Usually the cube would have 8 vertex

Heh…wouldn’t you know it? I enabled the depth buffer and turned off the DepthMask…


thanks for the help gang!