About 2 different waitFences in TriangleVulkan13

Hello,
in Sascha’s tutorial

in the base class VulkanExampleBase (base subfolder)
there is a member

std::vector<VkFence> waitFences;

And in the examples triangle and trianglevulkan13 (examples subfolders)
there is also a member of the same name

std::array<VkFence, MAX_CONCURRENT_FRAMES> waitFences{};

Is it not better to have different names for this two different variables?
I wonder why we should have the same name for two different variables

Or will I just remove the base member std::vector<VkFence> waitFences ?

Anyway, I checked it runs all right when I change the name
std::vector<VkFence> waitFences
to
std::vector<VkFence> waitMainFences

Thank you