10.6.3 screwed up my shaders!

my medical imaging software’s rendering is screwed up by this release of mac osx. I think it has something to do with opengl + x11.

Before:

After:

color bleeding all over the place. this is infuriating.

NOTHING has changed in my code. I cannot figure out how to fix this.
please help!

rendering on nvidia 1.6.10. is there a way to downgrade?

I don’t think that’s color bleeding. It looks more like a low colordepth.

Alfonse, I agree with you. Almost like I got a 16-bit surface. I have X11 set to millions. No clue how to get it to work. I’ve read other people having problems with X11 under 10.6.3 + OpenGL. One guy said indexed mode broke on him (no clue why he’s using that though).

I may have to wait for the movers to bring my usb hard drive and take the old X11.app from my time machine backup

Stupid sanity check -
Are you perhaps passing GL_RGBA/GL_RGB as the internalFormat to glTexImage when setting up your textures?

If you use that you will just get whatever format the driver decides on. (Cause of a lot of ATi/Nvidia differences)
You should always specify the bit format you want (typically GL_RGBA8/GL_RGB8)

sqrt. this makes sense, however similar output comes from rendering directly to the framebuffer using shaders that do not do texturing

so I’m thinking its an X11 opengl context problem.

update. it was X11. I installed latest XQuartz and colors are back.
apple really should test their updates better.